Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 9 of 9

Thread: Teensy 4.0 not working after soldering headers

  1. #1

    Teensy 4.0 not working after soldering headers


    I have a brand new Teensy 4.0 board.
    Upon reception, I tested it and it seemed to work (blinking LED).

    I then soldered the first header (2*24) and tried powering the device again... all good.
    I then soldered the 2nd header... but then, nothing upon power up. the board had stopped working!

    I checked for shorts or the like, but could not find anything, my solders looked clean.

    I tried unsoldering the headers, still nothing upon connection to the USB.

    Does anyone have any idea what might have gone wrong and what I can do to try to diagnose/fix the problem.


  2. #2
    Are you sure not solder got on any of the traces? How did you test for shorts? A continuity meter? I've soldered a few headers (3.2 and the mighty 4.1) and all worked for me.

  3. #3
    Senior Member+ KurtE's Avatar
    Join Date
    Jan 2014
    Two likely issues - A short or maybe your solder iron went a ways off and knocked off a component...

    In cases like this, a picture showing your board might help

  4. #4

    I used a ohm meter set at 2K and tested pin to next pin.
    Appart from the Gnd to 3.3V where I got 1Khom (I assumed consumption of the system), I got a no connection.

    I unsoldered/removed the header afterwards to try to see what/where I might have messed up. Here are the front/back pictures.
    I do not think that I had a wandering soldering iron as I was holding it from the outside of the PCB, blocked by the headers. I do not remember any slips. I do not seem to see any knocked out component either (which does not mean that they are not any)!

    Click image for larger version. 

Name:	IMG_1820.JPG 
Views:	28 
Size:	253.2 KB 
ID:	20745
    Click image for larger version. 

Name:	IMG_18192.jpg 
Views:	23 
Size:	135.2 KB 
ID:	20746

  5. #5
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Impressive that you were able to desolder the headers!

    When you plug in the USB, do you get 5V and 3.3V power? 5V is just a wire from the USB pin. 3.3V depends on the SNVS portion of the chip powering up, which raises the enable signal to turn on the 3.3V regulator.

  6. #6

    Well, I do have a de-soldering pump, it does help...
    I get 4.8V on the 5V, which I guess is more or less OK for the USB, although somewhat weak. but I tested said USB port on some other devices, and it seems to work (power up the other device, which gets recognized by windows).

    However, I get nothing on 3.3V (well, I get 0V).

    BTW, thanks for this boards, they are great. The is a pretty awesome chip (I am in fact working with one of it's beefier brothers the i.MX 6ULL, an A7 core, and it is a nice familly)!


  7. #7
    well, I was unable to revive the board. So I had to get another one. There, I was able to solder the headers and make it work.

  8. #8
    Senior Member
    Join Date
    Jul 2020
    I would check that your soldering iron tip is properly earthed.

  9. #9

    This is honestly something that I have never thought of!

    Anyhow, first, this would mean that I would put in doubt the quality work done by high level Chineese manufacturing.
    It would franckly be appealing if a $3.5 soldering iron did not have proper grounding!!! (

    Anyhow, the iron does not even have an hearth lead :-) so I doubt that it was earthed!

    Joke aside, I think that my issue was overheating. I had the iron set to max temperature, which is great because it solder super fast... but it might also slightly overheat the surroundings. Since the board is so small... it might not have been a good idea.

    I was able to get a 2nd board working properly however (after lowering the temperature).


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts