Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 11 of 11

Thread: Arduino IDE not working after loading teensyduino

  1. #1

    Arduino IDE not working after loading teensyduino

    So I recently loaded teensyduino onto my PC. I have a bunch of arduino sketches that previously worked fine.Since uploading the teensyduino many of my arduino Uno sketches not wont compile.I keep getting mutliple compile errors on files I have uploaded dozens of times before.I uninstalled the Adruino IDe and reinstalled in and I am still getting the same problem.I am not sure if this is the correct place to post or not.I have posted on the arduino forum too.I am guessing some libraries got corrupted by the teensyduino, but I am now dead in the water because I need to upload so UNO sketches into devices that I am selling and I catn get the sketches that worked fine previously to compile.I even tried downloading the sketches from the internet in case my souce files were corrupted and I get the same errors.

  2. #2
    Senior Member
    Join Date
    Oct 2019
    Might sound like a dumb question - but did you make sure the selected board is an Uno and not a Teensy or any other Arduino board?
    Click image for larger version. 

Name:	teensyduino_sc1_mini.png 
Views:	1 
Size:	27.4 KB 
ID:	20784

  3. #3
    yes I made sure the IDE was switched back to the UNO.Does the teensyduino chang ethe programmer setting in the Arduino IDE? I get a ton of compile errors on files that have compiled with zero errors before I installed the teensyduino

  4. #4
    Senior Member
    Join Date
    Oct 2019
    I would suggest you try compile one of your sketches and post the errors here - it will help troublshoot.
    Perhaps also state what environment you're set up on (OS, TD version etc) as it might be a bug if not another issue.

  5. #5
    here is the sketch.There are 12 files so it is split into 2 uploads
    Attached Files Attached Files

  6. #6
    the rest of the files and the error log from the compiler
    Attached Files Attached Files

  7. #7
    Sorry running this on an alienware r5 PC with Windows 10.The only thing that has changed recently is the teensy upload.before that this sketch compiled with no errors

  8. #8
    Senior Member+ KurtE's Avatar
    Join Date
    Jan 2014
    Sorry, I am not sure on how this compiles or doesnot. The log vile looks like excerpts of stuff...

    What would be good, is if you have a reasonably simple sketch that errors out now, that you copy and paste in the whole compile log... Better if you are setup to give a complete verbose output.

    That is go into Arduino preferences and check the verbose output on compilation, also show compiler warnings all.

    And again hard to now what all of the files you included are? Are these all part of one sketch file? Are they scattered in multiple libraries? If you have simple self contained sketch, would be good to create a zip file of all of these by using tools->Create Archive menu item and upload the zip.

    In theory the Teensyduino install will not impact your builds of Arduino UNO as all of the source files and libraries are stashed in a hardware branch that is not included in standard Arduino builds, unless your hardware type is one of the Teensy ones... But again this is assuming you are using Arduino to do the builds, and not Platform IO, or Visual Something or ...

  9. #9
    yes these are all part of one is a very complex program and the separate files are all inculed in the sketch. I will try a simpler program.This particular sketch is the one I really need to work as I use it in a device I sell and now I am stuck until I get can the compiler to work as it did.

  10. #10
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    I loaded your code here (clicked & downloaded every file - a single zip would have saved me some time).

    Your code compiles without error (but with a lot of warnings) for Arduino Uno using Arduino 1.8.5. It does not compile on Arduino 1.8.13. I did not test other versions, but from only this I'm pretty confident the problem is Arduino, not Teensyduino. If you look in their release notes, you'll see 1.8.13 upgraded the AVR toolchain. My guess is that's what broke your code, though I'll admit it's only a guess. I didn't dig any deeper than compiling your code with 1.8.13 and 1.8.5.

    To get back up and running again, just download Arduino 1.8.5 and use that old version. Teensyduino also supports 1.8.5, so you can use it for Teensy too. I'm pretty sure the Teensyduino installer won't get in your way, as I was able to compile your program on a copy of 1.8.5 with Teensyduino installed.

    Quote Originally Posted by darebyvet View Post
    I am not sure if this is the correct place to post or not.I have posted on the arduino forum too.
    Please think of everyone else who will later read these message. The least you can do is post a link here to the thread on Arduino's forum, and vise versa, so people reading on either forum can see the answers on the other forum.

    Also, as you continue to work on this code, I highly recommend using File > Preferences to turn on "All" compiler warnings.

  11. #11
    Sorry. I didnt realize I could load the whole folder as a zip file.

    For others with the same problem I found that running the arduino.debug solved my issue.I found this confusing initially, but then I realized when you run arduino.debug it uses an earlier version of the Arduino IDE.I am sure it is the AVR upgrades that crashed my program.

    There are no helpful comments so far on the arduino forum and I beleive they do not allow cross posting in their forum rules, but I will be happy to add their comments here once they have had a chance to review the error log file.

    Thank you for all of your help

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts