Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 3 of 3

Thread: midi poly pressure usb host issue

  1. #1

    midi poly pressure usb host issue

    hi there,

    when sending poly pressure out of a teensy 3.6 via usb-host port, it does not work properly.

    when i send the same data via usb-midi it works fine.

    sending poly pressure via usb-host results in VERY sporadic data being sent (only on note on maybe).

    i am sending the exact same command for both ports, see code snippet:

    Code:
    usbMIDI.sendPolyPressure(map_string_Fsr, active_Note[1], 3);
         for (int i=0; i<7; i++) {
          if (i != footpedal) {
    midilist[i]->sendPolyPressure(map_string_Fsr, active_Note[1], 3);
    midilist[i]->send_now();
    }
    for usb-host i am sending to 8 ports of a hub. i use this method for all different kinds of messages, aftertouch, note on and off, control change, pitchbend...it works on all messages except for poly pressure. could there be a bug in the usb-host midi implementation?

  2. #2
    a look at usb-host GitHub suggests the message has swapped variable input...

    Code:
    void sendPolyPressure(uint8_t note, uint8_t pressure, uint8_t channel, uint8_t cable=0) {
    		send(0xA0, note, pressure, channel, cable);
    	}
    will try this asap and report back...

  3. #3
    disregard my stupidity :-) it works flawlessly. of course usb-midi (non host) has the same order, but since i tested with PureData i never noticed (the polytouch) object just has outputs and i swapped them in the PD patch... all good.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •