Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 3 of 3

Thread: Adafruit_gfx, Teensyduino 1.53, Teensy 3.2

Hybrid View

  1. #1
    Junior Member
    Join Date
    Oct 2016
    Posts
    11

    Adafruit_gfx, Teensyduino 1.53, Teensy 3.2

    Just updated Arduino 1.8.13 (from 1.8.4) and Teensyduino 1.53 (from 1.44) and found that "Adafruit_gfx" is missing.
    Does this have any particular reason?
    I copied "adafruit_gfx" from Teensyduino 1.44, now my sketch compiles again.

  2. #2
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    23,001
    Adafruit_GFX was intentionally removed from 1.53, because the older copy we had was causing a lot of conflicts with several of Adafruit's libraries. Those conflicts have been an ongoing problem, so rather than update GFX again and (probably) have these problems return as Adafruit continues development of this library, I decided to remove it from the Teensyduino installer.

    The intended use is to install Adafruit_GFX using Arduino's library manager. In the beta testing for 1.53, we installed the latest Adafruit_GFX and checked it works with the remaining libs in Teensyduino which use it in some way.

  3. #3
    Junior Member
    Join Date
    Oct 2016
    Posts
    11
    Thanks for the quick reply.
    I have now installed it via the library manager. But it only works with older versions of adafruit_gfx (I think up to 1.5.x), with newer versions it hails error messages ... But the main thing is that it works. Will adjust my code if possible. Greetings from Austria.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •