I have recently purchased two of the MKL04Z32_TQFP32 chips from PJRC to program a DIY circuit using the MK20 (Teensy 3.2) chip. It will not connect to the USB on the PC. I have gone through the troubleshooting guide and resolved every issue I can imagine. I have attached a schematic that represents the circuit.
One thing I am not sure of is with respect to pin 4 of the Micro USB connector. Pin 4 has no connection, so the connection is only made between pin 10 of the MKL04 and pin 23 of the MK20.

Observations:

•Initially, the reset line shows positive going spikes. I understand this to be the MK20 attempting to reset itself. The MKL04 appears to be working, since grounding pin 10 of the MKL04 causes the reset line to go low, followed by the reset line going high. (It sometimes takes several attempts for this to happen).

•When the reset line goes high, continuous data can be observed from pins 15 and 16 of the MKL04. There are some minor overshoots, but it is basically 0-3.3 and looks reasonable.

•Data has NEVER been observed on the USB lines. Whether it is following a reset, a power cycle, or anything, data never seems to be observed. Checked both sides of the 33 ohm resistors.

•All pin connections have been verified several times.

•NMI pin 26 is not connected, and is at a high level.

•The 16MHz crystal does NOT show oscillation.

•When the reset line does go high, it appears to be noisier than expected. (noise is about 0.4Vpp, going from about 3.0 to 3.4)

Notes:

•I haven’t used all of the decoupling caps, but I do have a beefy 470uF electrolytic and 2uF tantalum capacitor on the 3.3V line. It looks pretty clean.

•I am using ZIF sockets for both the MKL04 and MK20. They are not soldered. So there is a fair amount of “spaghetti” wire, but I’ve tried to keep then generally clear of noise.

Things that have been tried:

•Tried grounding the pin 10 to pin 23 connection. (Saw where some cables apparently ground the USB sense line pin 4).

•Tried using 5V from the USB as input to the 3.3V regulator, as well as an external 5V to the 3.3V regulator.

•Tried reversing the USB data lines.

•Confirmed the USB pinout, processor pinouts, etc. Confimred 33 ohm resistors.

•Tried both MKL04 chips that I have purchased, and they both act the same.

•Tried both MK20 chips that were purchased from Digi-Key, although only one of them appears to generate the pulses on the reset line, and appears to be “working”, so to speak.

Click image for larger version. 

Name:	teensyConnection.png 
Views:	32 
Size:	48.8 KB 
ID:	21282