Forum Rule: Always post complete source code & details to reproduce any issue!
Page 2 of 2 FirstFirst 1 2
Results 26 to 31 of 31

Thread: Error on second compile after Teensyduino and Arduino update

  1. #26
    Senior Member+ KurtE's Avatar
    Join Date
    Jan 2014
    Posts
    7,642
    I wonder if this is related to https://github.com/arduino/Arduino/issues/10354

  2. #27
    Senior Member+ defragster's Avatar
    Join Date
    Feb 2015
    Posts
    12,380
    Good find KurtE - looks very relevant ... back to IDE 1.8.10 ...

  3. #28
    Senior Member
    Join Date
    Jul 2020
    Posts
    174
    Windows 10 Home, version 2004.
    Arduino 1.8.13.
    Teensyduino 1.53.

    Example from Blink.ino:
    Code:
    [
      {
        "Sourcefile": null,
        "Include": "",
        "Includepath": "D:\\Program Files\\arduino-1.8.13\\hardware\\teensy\\avr\\cores\\teensy4"
      },
      {
        "Sourcefile": "C:\\Users\\User\\AppData\\Local\\Temp\\arduino_build_751549\\sketch\\Blink.ino.cpp",
        "Include": "",
        "Includepath": null
      }
    ]
    Still crashes unless I remove the includes.cache file.

  4. #29
    Senior Member
    Join Date
    Jul 2020
    Posts
    174
    Quote Originally Posted by KurtE View Post
    That's precisely what it is.

    I guess tomorrow I will go to 1.8.10 and see if it works.

  5. #30
    Senior Member+ KurtE's Avatar
    Join Date
    Jan 2014
    Posts
    7,642
    I am not an expert on this, but again wonder what is different about your machine? and how Arduino is installed?

    For example again is it an issue with administrator versus user who is not... Virus protection software...

    Also things to try. Did you try changing the Arduino preferences? in the file preferences.txt Note: as the IDE mentions, when you change this file you need to not be running the IDE...

    But you might look for lines like:
    Code:
    cache.enable=true
    compiler.cache_core=true
    And change one or both to false and see if that helps.

  6. #31
    Senior Member
    Join Date
    Jul 2020
    Posts
    174
    Quote Originally Posted by KurtE View Post
    But you might look for lines like:
    Code:
    cache.enable=true
    compiler.cache_core=true
    And change one or both to false and see if that helps.
    That would effectively be the same thing as deleting the cache file, so it would work for people who don't use a Build.cmd (i.e. those who are building from inside the Arduino IDE.)

    Went back to 1.8.9 and it will compile over and over, while using the cache. It's not the huge speedup I was hoping for, but now the compilation has gone from ~17 seconds to about 10. Doesn't hold a candle to PHP, but good enough!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •