Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 3 of 3

Thread: Teensy 3.2 fails to start up (hardware)

  1. #1

    Teensy 3.2 fails to start up (hardware)

    I build several models of the "Teensy SDR" using the Teensy 3.2 and audio board. All work except one which has an odd problem. The last time I tried it about a month ago it did not come up - this one uses a 1.8" LCD display and the backlight was lit but there was no display or response to any controls. However after fooling with it for a while, power cycling, leaving power applied, etc - it started working. And of course then I couldn't reproduce the problem.

    I set it aside and today tried it again, and just as before, the CPU appears to not be running. The LCD backlight is on but there is no display (SPI) and no activity on the I2C bus either. I provide 5 volt power to the Teensy board and that source is up and clean and I use a bit of the 3V3 supply which is also at 3.3V and clean. I haven't attempted to do any troubleshooting on the Teensy board itself or try to verify that the clocks are running, but I did verify there is no response to the Reset button and removing the I2C and 3v3 loads made no difference. This is the only issue like this I've encountered in a half dozen or so Teensy 3.2s.

    Any suggestions would be appreciated!

    Thanks,
    Bob

  2. #2
    I can now add that there's no activity at the crystal.

    Bob

  3. #3
    And I can close this issue, it's not hardware after all.

    It's been well over a year, and I'd forgotten that I'd enabled serial debugging, and it was waiting for the serial console to become available. After connecting to a PC and opening the serial monitor, the Teensy sprang to life.

    Sorry for the noise!

    Bob

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •