Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 7 of 7

Thread: Teensy 4.0 Shield ??

  1. #1
    Junior Member
    Join Date
    Aug 2020
    Posts
    17

    Teensy 4.0 Shield ??

    I want to use an Arduino UNO shield with my Teensy 4.0. I see there is a shield that fits Teensy 3.1 & 3.2, but I need one for the Teensy 4.0.

    Does anyone make one for the Teensy 4.0?

  2. #2
    Senior Member+ MichaelMeissner's Avatar
    Join Date
    Nov 2012
    Location
    Ayer Massachussetts
    Posts
    3,879
    Unfortunately the seller is on vacation until the end of September:


    I bought the revision 1 board and I found the micro SD card was unusable. The revision 2 board evidently fixes those problems. But I must admit, I haven't done anything with mine since buying it. The teensy 4.1 came out with built-in SD card also reduced one of the reasons I bought it.

  3. #3
    Junior Member
    Join Date
    Aug 2020
    Posts
    17
    The PJRC site says, "Teensy 4.0 is the same size and shape as Teensy 3.1, and retains compatibility with most of the pin functions on Teensy 3.2"

    So I ordered the SparlkFun shield for the 3.1. I'll let you know if it works or not.

  4. #4
    Senior Member
    Join Date
    Jul 2020
    Posts
    463
    Remember 5V is death to the Teensy 4, its 3.3V only. The 3.1 and 3.2 are 5V tolerant so a shield adapter won't put
    those at risk from a 5V shield, but the T4 will die in this situation without level-shifting on the adaptor.

  5. #5
    Senior Member+ MichaelMeissner's Avatar
    Join Date
    Nov 2012
    Location
    Ayer Massachussetts
    Posts
    3,879
    I put this page on the unofficial wiki about Teensy compatibility:

  6. #6
    Senior Member+ MichaelMeissner's Avatar
    Join Date
    Nov 2012
    Location
    Ayer Massachussetts
    Posts
    3,879
    Quote Originally Posted by MarkT View Post
    Remember 5V is death to the Teensy 4, its 3.3V only. The 3.1 and 3.2 are 5V tolerant so a shield adapter won't put
    those at risk from a 5V shield, but the T4 will die in this situation without level-shifting on the adaptor.
    IIRC, newer Arduino shields should be able to run with either 3.3v or 5v power. The Teensy would run the shield at 3.3v. Older shields are 5v only, and you probably want to use just the Teensy 3.2 and 3.5 processors with those old shields.

  7. #7
    Junior Member
    Join Date
    Aug 2020
    Posts
    17
    Quote Originally Posted by MichaelMeissner View Post
    I put this page on the unofficial wiki about Teensy compatibility:
    This is great information. Looking at all the options available at the moment, it appears the Teensy 3.3 which is 5V tolerant is my best option. Thank you!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •