Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 4 of 4

Thread: Problem with adapter for using a Rev. B audio shiel with a T_4.1 (for MicroDexed)

  1. #1
    Senior Member
    Join Date
    May 2018
    Posts
    127

    Problem with adapter for using a Rev. B audio shiel with a T_4.1 (for MicroDexed)

    Hi,

    I made an adapter board for using a T_4.1 as a replacement for the T_3.6 on my TMA boards. This adapter maps the used pins to new destinations - especially the I2S pins.

    Everything works (encoders, I2C display, MIDI-I/O) but the audio seems to have problems. I am getting much strange noise when starting up. When recording via USB-Audio everything sounds fine, only on audio out there is strange noise (with played notes in the background).

    Pin assignment is double checked and with the T_3.6 everything works fine.

    I am using a Rev B board. So my predefined answers are:

    [ ] Your I2S signals may be garbled by your PCB routing and the adapter.
    [ ] You really need to add a 100 Ohm resistor into the MCLK line for a Rev A or B audio board.
    [ ] You idea, throw everything away and do something you know about.

    TIA, Holger

  2. #2
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    23,069
    The 100 ohm resistor is absolutely required with Teensy 4.0 & 4.1, even if the wires are short.

  3. #3
    Senior Member
    Join Date
    May 2018
    Posts
    127
    Quote Originally Posted by PaulStoffregen View Post
    The 100 ohm resistor is absolutely required with Teensy 4.0 & 4.1, even if the wires are short.
    Thanks, Paul. So I will try to add one to my adapter board.

  4. #4
    Senior Member
    Join Date
    May 2018
    Posts
    127
    Thanks, it works fine with my patched Adapter:

    Click image for larger version. 

Name:	T41adapter.jpg 
Views:	3 
Size:	83.8 KB 
ID:	22394

    More questions:
    - Do I need this resistor also for Rev C boards? is it problematic if the resistor is also used for Rev C?
    - Can/should I add the resistor also for Rev A/B boards when using a T_3.6?

    My T_3.6 has some quiet noise in the background wchi the T_4.1 does not have...

    Regards, Holger

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •