Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 3 of 3

Thread: SdFat and teensy 3.2 (no longer supported?)

  1. #1
    Senior Member
    Join Date
    Jun 2015
    Posts
    134

    SdFat and teensy 3.2 (no longer supported?)

    Hello

    Does this library no longer work with teensy 3.2? https://github.com/greiman/SdFat

    I am on Arduino 1.8.12
    Installed latest SdFat lib via library manager.

    When compiling for 3.2 I just get

    "TeensySdioDemo:16: error: 'SdFatSdio' does not name a type
    SdFatSdio sd;"

    But if i compile for 3.5 it compiles fine. I have done some research and it appears people did use this lib back in the day on the teensy 3.2? or was there a different version?

    Regards
    Russell

  2. #2
    Senior Member
    Join Date
    Jul 2014
    Posts
    2,769
    T3.2 does not have SDIO, you must use SPI

  3. #3
    Senior Member
    Join Date
    Jun 2015
    Posts
    134
    Ah yes of course, all working thank you

    Regards
    Russell

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •