Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 5 of 5

Thread: Teensy 3.5 diy build with MK64FX512VLQ12

  1. #1
    Junior Member
    Join Date
    Dec 2019
    Posts
    15

    Teensy 3.5 diy build with MK64FX512VLQ12

    Hi,
    We have been using the teensy 35 board for a while and I'm now at a point where I really need to build my own teensy 35 on a custom board. I'd like to keep the board layers down to minimise cost of fabrication so have decided to select the leaded devices.

    I've based a design around the IC_MKL04Z32_TQFP32 (purchased from PJRC) and the MK64FX512VLQ12.

    Its a shame there is no single source of collated information for carrying out these builds but I have read the notes and linked posts found from the following link.
    https://www.pjrc.com/store/ic_mkl02.html

    I've had the PCB board built based on the schematic attached, but after assembly it hasn't worked. I've checked the soldering and buzzed out the connections.

    Would someone be able to confirm if I've made a simple mistake in the design? If it looks ok I'll have to dig a bit deeper into fault finding the actual board.

    really appreciate any help.

    cheers
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	diy35_schematic.jpg 
Views:	45 
Size:	65.6 KB 
ID:	22665  

  2. #2
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    25,082
    Maybe try sharing a PDF. The forum limits the max size of images, which makes this very hard to read.

  3. #3
    Junior Member
    Join Date
    Dec 2019
    Posts
    15
    pdf attached...
    Attached Files Attached Files

  4. #4
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    25,082
    I looked briefly at your schematic. Nothing I can see looks out of the ordinary. For the sake of testing, I would remove the MIC803 chip, even though it should be ok.

    Have you tried any of the troubleshooting tips mentioned in the forum threads linked from the "Troubleshooting" section on the MKL02 page?

    https://www.pjrc.com/store/ic_mkl02.html

    In particular, the first one suggests measuring the voltage on the Program (pushbutton) and Reset pins. A virgin board should have 3.3V on the Program pin due to the code inside the MKL02 turning on that pin's pullup resistor. That 3.3V can confirm whether the MKL02 booted and initialized its hardware.

    The Reset pin should be pulsing high for brief times as the MK64 chip keeps watchdog rebooting. Typically a DC voltage measurement will show only about 0.2V, but not zero, because it is high for brief times. Easy to see with an oscilloscope of logic analyzer.

    When you short the Program pin to GND using the pushbutton, the MKL02 is supposed to respond by pulling Reset low for as long as you keep Program low. So even if you have only a DC voltmeter, you can observe the ~0.2V from the short pulses become ~0 volts. That chance can confirm whether the MKL02 is still running.

    Anyway, I see nothing obviously wrong with the schematic, though this non-schematic style of using only net names to make all your connections is tedious to verify. I could have easily missed a minor detail like a net name spelled wrong in 1 location.
    Last edited by PaulStoffregen; 12-02-2020 at 10:56 AM.

  5. #5
    Junior Member
    Join Date
    Dec 2019
    Posts
    15
    Thanks Paul, I just was looking for a bit of reassurance before digging to deep into fault finding something that would never work.

    I did have a quick look at the reset pin, but it had nothing on it. so ill dig around that area a bit more. It might have something to do with a power supervisor device I've added to this circuit.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •