Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 18 of 18

Thread: Teensy4.1 intall does not work

  1. #1
    Junior Member
    Join Date
    Dec 2020
    Posts
    12

    Teensy4.1 intall does not work

    Hi I, am not able to use Teensy 4.1 with Arduino because Teensy4.1 Install will not Install. I found this error lib/version.txt file missing.

    I would appreciate help.

    Sincerely,

    soky157

  2. #2
    Senior Member+ KurtE's Avatar
    Join Date
    Jan 2014
    Posts
    8,470
    Sorry not enough info to guess. What os?What version of arduino was installed. What version of teensyduino did you try to install?

  3. #3
    Senior Member manicksan's Avatar
    Join Date
    Jun 2020
    Location
    Sweden
    Posts
    225
    It looks like the version.txt is missing in the arduino installation, you can create one yourself what version of arduino do you have installed?

  4. #4
    Senior Member manicksan's Avatar
    Join Date
    Jun 2020
    Location
    Sweden
    Posts
    225
    The content should look like this (plain and simple but with your version instead)
    https://raw.githubusercontent.com/te...ib/version.txt

  5. #5
    Senior Member+ defragster's Avatar
    Join Date
    Feb 2015
    Posts
    13,464
    Is this on Windows or other?

    See this page for OS specific details in any case : pjrc.com/teensy/td_download.html

    If Windows was it a ZIP or Installer from the Arduino site? Windows Store version does not work with TeensyDuino.

    From : arduino.cc/en/software
    Either of these work:
    Code:
    DOWNLOAD OPTIONS
    Windows     Win 7 and newer
    Windows     ZIP file
    This does not:
    Code:
    Windows app     Win 8.1 or 10

  6. #6
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    23,742
    Usually this error happens on Linux when attempting to install into a distro-provided copy of Arduino.

    Only the original Arduino IDE from Arduino.cc website is supported. The many modified copies from Linux distros are not supported.

  7. #7
    Senior Member manicksan's Avatar
    Join Date
    Jun 2020
    Location
    Sweden
    Posts
    225
    A question do your teensyduino install contain all versions of the arduino pde.jar and arduino-core.jar for all supported versions of arduino ide?

  8. #8
    Senior Member+ defragster's Avatar
    Join Date
    Feb 2015
    Posts
    13,464
    Quote Originally Posted by manicksan View Post
    A question do your teensyduino install contain all versions of the arduino pde.jar and arduino-core.jar for all supported versions of arduino ide?
    The 'download' link in p#5 notes which versions of the IDE are supported. For supported versions the installer maintains the needed java files to complete a working install on those known versions.

    Current TD 1.53 shows : Teensyduino 1.53 supports Arduino versions 1.8.5 and 1.8.9 and 1.8.11 and 1.8.12 and 1.8.13.

    That changes over time when releases have known issues, or they age out beyond some 'milestone' release. Current note on that page shows: Future versions of Teensyduino will drop support for Arduino 1.8.11

  9. #9
    Senior Member manicksan's Avatar
    Join Date
    Jun 2020
    Location
    Sweden
    Posts
    225
    I have now checked little how it checks for certain files:
    It actually matches a The Arduino Version in arduino.txt with
    known filesizes of the existing files, (it looks by the way that it allows the same version of teensyduino to be reinstalled)

    Checking Arduino 1.8.13:
    version: "lib/version.txt" version matches
    file: "arduino.exe" present
    file: "arduino_debug.exe" present
    file: "lib/jssc-2.8.0-arduino4.jar" present
    java: "lib/pde.jar" object: "processing/app/Base.class" checksum match
    java: "lib/pde.jar" object: "processing/app/Editor.class" checksum match
    java: "lib/pde.jar" object: "processing/app/SketchController.class" checksum match
    java: "lib/arduino-core.jar" object: "processing/app/BaseNoGui.class" checksum match
    java: "lib/arduino-core.jar" object: "cc/arduino/Compiler.class" checksum match
    java: "lib/arduino-core.jar" object: "processing/app/debug/TargetPlatform.class" checksum match
    Found Arduino 1.8.13


    The conclusion is that you cannot install Teensyduino on an modified version of arduino ide.

  10. #10
    Junior Member
    Join Date
    Dec 2020
    Posts
    12

    Teensy 4.1

    How is my Arduino Ide modified? I am using vs 18.3








    Quote Originally Posted by manicksan View Post
    I have now checked little how it checks for certain files:
    It actually matches a The Arduino Version in arduino.txt with
    known filesizes of the existing files, (it looks by the way that it allows the same version of teensyduino to be reinstalled)

    Checking Arduino 1.8.13:
    version: "lib/version.txt" version matches
    file: "arduino.exe" present
    file: "arduino_debug.exe" present
    file: "lib/jssc-2.8.0-arduino4.jar" present
    java: "lib/pde.jar" object: "processing/app/Base.class" checksum match
    java: "lib/pde.jar" object: "processing/app/Editor.class" checksum match
    java: "lib/pde.jar" object: "processing/app/SketchController.class" checksum match
    java: "lib/arduino-core.jar" object: "processing/app/BaseNoGui.class" checksum match
    java: "lib/arduino-core.jar" object: "cc/arduino/Compiler.class" checksum match
    java: "lib/arduino-core.jar" object: "processing/app/debug/TargetPlatform.class" checksum match
    Found Arduino 1.8.13


    The conclusion is that you cannot install Teensyduino on an modified version of arduino ide.

  11. #11
    Junior Member
    Join Date
    Dec 2020
    Posts
    12
    Hi i am using version 18.3

  12. #12
    Junior Member
    Join Date
    Dec 2020
    Posts
    12
    Hi i have version 18.3 of Arduino installed

  13. #13
    Junior Member
    Join Date
    Dec 2020
    Posts
    12
    Hi, Hi i am using version 18.3 of Arduino

  14. #14
    Senior Member+ Frank B's Avatar
    Join Date
    Apr 2014
    Location
    Germany
    Posts
    7,937
    There is no version 18.3
    Just do what Paul said. Download 1.8.13 from the Arduino website. No need to check any version files etc.
    That makes all unnessary complicated. Don't try to find the problem. Download & new install is much easier and faster, and works out of the box.

  15. #15
    Junior Member
    Join Date
    Dec 2020
    Posts
    12
    Forgot to mention I am using Windows PC and Arduino 18.03

  16. #16
    Senior Member+ Frank B's Avatar
    Join Date
    Apr 2014
    Location
    Germany
    Posts
    7,937
    Yes.
    Un-install that.
    Download the Windows 1.8.13 version (zip-file), install it (best is, to an new folder "c:\Arduino"), then Teensyduino.

  17. #17
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    23,742
    Arduino's website has 3 downloads for Windows. Only 2 of them work with Teensyduino.

    Click image for larger version. 

Name:	sc.png 
Views:	8 
Size:	22.6 KB 
ID:	23417

    Any chance you actually have this "Windows app" version?

  18. #18
    Junior Member
    Join Date
    Feb 2021
    Posts
    7
    I was able to get it to install only when the Arduino IDE was installed in its default location.

    (I used to have it installed on a different drive than the default. Teensyduino did not accept the directory entries and would not activate the "Next" button.)

    Apparently, the install scrutinizes your Arduino installation and requires a certain structure. I added a "Teensy" directory to put it in, and the installer would not install. I removed the directory and then it installed.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •