Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 6 of 6

Thread: Setting T4.x USB device speed to 12 MHz?

  1. #1
    Senior Member
    Join Date
    Jul 2014
    Posts
    3,155

    Setting T4.x USB device speed to 12 MHz?

    How to set the USB dev speed on T4.1 to 12 MHz?
    I wanted the connect to T4.1 USB via some connectors, but I only get unknown device on my PC.
    I suspect that the waveform gets disturbed too much when passing through non USB type connectors.
    For testing I wanted to use 12 MHz speed to see if this is a solution.

  2. #2
    Senior Member+ Frank B's Avatar
    Join Date
    Apr 2014
    Location
    Germany
    Posts
    8,282
    Do you have an old 12MHz Hub? Don't know if that would work..I'm courious.

  3. #3
    Senior Member
    Join Date
    Jul 2014
    Posts
    3,155
    No,
    I have a very tight space (not large enough for a USB connector) so USB data dots are connected to a PCB connector that is connected to a Underwater Bulkhead etc.
    All in a water tight pressure housing.
    An earlier version used T3.6 with no problem, but T4.1 creates problems:
    USB device nor recognized or is recognized, download blocks halfway through; a nightmare
    No time to revert to T3.6; need also external memory.

  4. #4
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    24,098
    Try uncommenting this line in usb.c

    Code:
            //USB1_PORTSC1 |= USB_PORTSC1_PFSC; // force 12 Mbit/sec

  5. #5
    Senior Member
    Join Date
    Jun 2017
    Posts
    153
    Paul,

    My apologies to all for hijacking this thread, but I don't know what else to do. I ordered and received 2ea ILI9341 displays from your store 2 weeks ago, and one of them appears to be DOA. I emailed both you and Robin at 'Paul@pjrc.com' and 'Robin@pjrc.com' a week ago about this but haven't gotten any replies. I also started a topic 'Getting Product Support' in the 'General Discussion' forum category, but no responses there either.

    Is there something I'm doing wrong here, or is product support no longer available?

    Apologies again,

    Frank

  6. #6
    Senior Member
    Join Date
    Jul 2014
    Posts
    3,155
    Quote Originally Posted by PaulStoffregen View Post
    Try uncommenting this line in usb.c

    Code:
            //USB1_PORTSC1 |= USB_PORTSC1_PFSC; // force 12 Mbit/sec
    Seems to work.
    At least Teensy talks to PC using flying wires and can download (the main reason for functionality)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •