Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 3 of 3

Thread: Installation issues with Teensyduino 1.53 on Arduino 1.8.13 on Ubuntu 18.04 LTS

  1. #1
    Junior Member
    Join Date
    Apr 2019
    Posts
    17

    Installation issues with Teensyduino 1.53 on Arduino 1.8.13 on Ubuntu 18.04 LTS

    sorry for the n00b questions, but I'm getting errors regarding the udev rules, installer seems to be looking at 49- instead of 00- even though I've copied it to etc and I'm trying to install the latest teensyduino.

    ERROR in /etc/udev/rules.d/49-teensy.rules

    I have an older version already installed, I think, but I did an upgrade to from Ubuntu 16 to 18 since then, not seeing Teensyduino on my system anymore.

    tried following the exact steps on the install page but getting hung up on the rules check. Tried deleting 49- from etc but now I get this:

    ERROR in /etc/udev/rules.d/49-teensy.rules

    The file does not seem to exist, or directory permissions are blocking this installer from accessing /etc/udev/rules.d

    To fix this problem, run this command in a terminal:
    sudo cp /tmp/49-teensy.rules /etc/udev/rules.d/

    I've rebooted twice as that seemed to be one way to fix rules issues, but no joy.

    any tips or ideas?

  2. #2
    Junior Member
    Join Date
    Apr 2019
    Posts
    17
    tried renaming 00- to 49-, failed.

    then there was a suggestion in the failure dialog to cp rules from /tmp... to /etc... and that worked!!!

    so I guess the instructions on the installer web page are wrong.

  3. #3
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    24,111
    The udev rules changed since 1.53 was released.

    Here are 3 possible solutions.

    1: Run "sudo cp /tmp/49-teensy.rules /etc/udev/rules.d/" as the installer suggests. That will put the 1.53 version of udev rules onto your system.

    2: Install the latest 00-teensy.rules, and when the 1.53 installer complains, click the button to skip the udev rules check.

    3: Install 1.54-beta7 which uses the new udev rules. It also has fixes for issues on Ubuntu 20.04.2 (but should be backwards compatible to Ubuntu 14).

    Sadly, in recent years udev on Linux has become quite a moving target. Some systems have a bug where certain pattern matching just doesn't work. Sometimes it's case sensitive, sometimes not. I even found a bug on 18.04 where an unrelated udev rule gave permission for some of Teensy's interfaces, causing other problems to be masked until used on newer systems where that bug is fixed. We also found on slow systems like Jetson Nano that the 00 filename avoiding timing problems, which motivated the filename change. And that's all on top of the ModemManager udev bugs that surfaced when Ubuntu changed its default filter policy!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •