Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 3 of 3

Thread: teensy 3.2 does not run when add step down and give power from wall supply!

  1. #1

    teensy 3.2 does not run when add step down and give power from wall supply!

    Hi ,

    I have the teensy 3.2 and when give power from 4X1.2 NiMh Battery ->4.8Volt to Vin and GND the teensy working well,when connect and disconnect the battery, the teensy starts running!

    Now the problem!
    When i try to use wall AC230volt to DC 12V 1000mA or batterys 2X3.6volt li-ion and after use step down to get 5 volt output and give the 5Volt to Vin and GND on teensy, not working when cut or give power from wall transformer or battery , but if cut and disconnect the cable after from step down the teensy starts running OK!

    how do i get teensy to start running when connecting and disconnecting the cable before the step down?

    this also happens to me in the simple code of led blinking!


    Thank you!!

  2. #2
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    24,078
    Very difficult to say what's going wrong here, but it does remind me of painful problems as couple people experienced with Traco DC-DC step down converters they bought from Adafruit. As I recall, the Traco datasheet said an extra capacitor located close to its input terming was only necessary if the input voltage was fairly high. But testing showed it performed terribly at startup without that capacitor, even at the lower end of its range.

    Just to repeat for clarity, the capacitor was needed between the Traco input and GND. Adafruit eventually updated their web page and initially gave a wrong impression to put the capacitor on the output (seems they give that advice for lots of power supplies) but the DC-DC converter startup problems were due to not having a capacitor on the input side.

    I have no idea which DC-DC converter you're using, or if it would even do something so terrible as that little Traco part did. If this doesn't help, maybe give us more details and photos of what you're really using.

  3. #3
    Quote Originally Posted by PaulStoffregen View Post
    Very difficult to say what's going wrong h..........
    If a capacitor needs to be added, what capacitance should it have?

    I have this https://grobotronics.com/dc-dc-conve...own-5v-1a.html
    Μaybe as mentioned the problem may be in DC to DC step down to 5V!
    I will look to get another step down DC to DC 5volt and try it again!

    see the attached photo the wall power supply and the circuit with dc to dc.

    Next..
    I tried with a 1X3.6volt battery lithion and with DC to DC step up to 5volt and it works teensy OK.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	_20210416_155751.jpg 
Views:	2 
Size:	48.4 KB 
ID:	24467   Click image for larger version. 

Name:	_20210416_155827.jpg 
Views:	4 
Size:	113.1 KB 
ID:	24468  


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •