Forum Rule: Always post complete source code & details to reproduce any issue!
Page 2 of 2 FirstFirst 1 2
Results 26 to 31 of 31

Thread: Teensy LC EEPROM Bug Demonstration Program

  1. #26
    Member
    Join Date
    Dec 2017
    Location
    Ohio
    Posts
    56
    I did place it in the correct folder...I was just checking. Thanks!

  2. #27
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    24,497
    Teensyduino 1.54-beta10 now has the fix for this Teensy LC emulated EEPROM corruption issue.

    https://forum.pjrc.com/threads/67516...o-1-54-Beta-10

    If anyone is still watching this thread and experiencing this problem, please install 1.54-beta10. Does it fully solve the problem for your EEPROM-usage application?

  3. #28
    Member
    Join Date
    Dec 2017
    Location
    Ohio
    Posts
    56
    I installed the Beta patch and tried to compile our SDR project; a non-trivial affair with 19 source files and about 11K lines of code. I got just under a bazillion errors from the linker. After I installed new copies of the Time and SD libraries, things are back to normal. I'm sorry I didn't save the error messages to a file, but there were so many I don't know how useful that would have been. Looking at the list, however, suggested problems on my system with those two libraries and reinstalling them fixed whatever issue it was. If anyone else is having issues with the Beta, perhaps this note will help point them in the right direction.

  4. #29
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    24,497
    Quote Originally Posted by econjack View Post
    I installed the Beta patch and tried to compile our SDR project...
    So after updating libraries, what's the verdict on EEPROM corruption? Does the new version fully solve the problem?

    I did test here and it solved all the problems I could see, but the real question is whether it's really working well for you now?

  5. #30
    Member
    Join Date
    Dec 2017
    Location
    Ohio
    Posts
    56
    I was not using the LC and it turns out there may have been a hardware failure on the T4.1. I had a spare and downloaded the Beta and got the error messages I mentioned earlier. Because most of the error messages thrown by the linker referred to the Time and SD libraries, I reinstalled those. Now everything is working perfectly, including the EEPROM code. I tried to order a replacement T4.1, but like we're seeing so often now, there's no stock. Any idea how long before you're resupplied?

  6. #31
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    24,497
    Quote Originally Posted by econjack View Post
    I tried to order a replacement T4.1, but like we're seeing so often now, there's no stock. Any idea how long before you're resupplied?
    Short answer, Teensy 4.1 returning early next month. Some distributors still have low stock.

    Longer answer, https://forum.pjrc.com/threads/67544...in-July-(2021)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •