Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 8 of 8

Thread: Can't install on ubuntu

  1. #1

    Can't install on ubuntu

    When I try to install Teensyduino on ubuntu, it's not working. How should I proceed?

    I created the file https://www.pjrc.com/teensy/00-teensy.rules like described in the docs. Then dowloaded the installer for linux.
    When I run it, it say `/etc/udev/rules.d/49-teensy.rules` does not exist. But then I did `sudo cp /tmp/49-teensy.rules /etc/udev/rules.d/` and it worked.

    Now I want to select the folder where arduino is install, so I give `/snap/arduino/current/` but doesn't work. I try to run it why the command like: `./TeensyduinoInstall.linux64 --dir=/snap/arduino/current` but I get

    Code:
    Directory "/snap/arduino/current/" is not a supported Arduino
     Arduino versions supported: 1.8.5, 1.8.9, 1.8.11, 1.8.12, 1.8.13
    or if I run `/snap/arduino/current/arduino --version`
    I get:
    Code:
    Picked up JAVA_TOOL_OPTIONS: 
    Loading configuration...
    Initializing packages...
    Preparing boards...
    Arduino: 1.8.13
    So now I don't know what to do :-/ Can anyone help with this?

  2. #2
    Senior Member+ KurtE's Avatar
    Join Date
    Jan 2014
    Posts
    9,553
    Sorry I am not 100% sure of your setup. Also I do most of my stuff on Windows, but do keep a machine with Ubuntu...

    Might help to know what version of Ubuntu, running on? 32 bit or 64 bit...

    Also Teensyduino needs to be installed to work with some version of Arduino, which is downloaded from the Arduino.cc locations. It does not work (or at least did not) with versions of Arduino that can be installed through unbuntu using tools like: apt-get install or ... And I am guessing that snap is doing something of that nature.

    So again I am guessing, what you need to do is to go and download directly from: https://www.arduino.cc/en/software

  3. #3
    I am using Ubuntu 20.04.2 LTS. The installer doesn't seem to work with snap package. When I download arduino from the arduino website, the installer work, but I still don't see anything in the arduino IDE.

  4. #4
    Ok, I got it to work, as said in your doc, we can't use the package installer for arduino, we need to do it from the zip :-/

  5. #5
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    25,022
    Quote Originally Posted by apiel View Post
    but I still don't see anything in the arduino IDE.
    I can't see your screen and I know know precisely what you're clicking and typing, but my best guess is you may have installed Teensyduino into a copy of Arduino you downloaded from Arduino.cc (the only thing Teensyduino supports), but then perhaps you ran Ubuntu's copy of Arduino rather than the copy where you installed Teensyduino?

    In Arduino, click Help > About to check the version. If Teensyduino is installed in that copy of the Arduino IDE, you'll see it in the upper right corner of the About info. And of course Teensy will be in the Tools > Boards menu.

    You might also consider using 1.54-beta7 if you have Ubuntu 20.04.2. Teensyduino 1.53 and older were really only ever tested on Ubunut 18.04.

    https://forum.pjrc.com/threads/66357...no-1-54-Beta-7

    It turned out Ubuntu 20.04.2 has a broken GTK2 library. It's strange, because GTK2 worked on 20.04 and 20.04.1, and even works if you originally installed either of those and then upgraded to 20.04.2 without a clean reinstall. But if you install starting with 20.04.2, you get a broken GTK2 where Teensy Loader takes about 25-30 seconds to open. Starting with 1.54-beta7 we're linking with GTK3 rather than GTK2. The udev rules were also updated to deal with issues that have come up on newer Linux distros. Make sure you installed the file that begins "00" not the older "49" udev rules.

  6. #6
    Is it possible to run the compiler for arduino from the command line? cause seem that teensyduino doesnt work well with the vscode version of arduino

  7. #7
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    25,022
    Quote Originally Posted by apiel View Post
    Is it possible to run the compiler for arduino from the command line?
    Yes. Look on the product page.

    https://www.pjrc.com/store/teensy41.html

    Scroll down to "Software" and look for "Command Line with Makefile".

    Similar info is also on the Teensyduino download page.

    https://www.pjrc.com/teensy/td_download.html

    Scroll down to "Command Line Install". But again, if you're using Ubuntu 20.04.2 (where the .2 update was published only 1 month ago, February 2021) you might wish to use 1.54-beta7 rather than 1.53.

  8. #8
    I know I'm responding to an oldish thread, but I also ran into a problem installing Teensyduino with a Snap installation of the Arduino IDE and had to install from the .zip file. When I had tried installing over the Snap version, it got to the "Select Arduino Folder" part of the Teensyduino installer, but the "Next" button was always grayed out. I believe that it may have to do with the Teensyduino installer looking at the lib/version.txt file, which looks quite different between the two. In the .zip version, the version.txt file has "1.8.13" in it. In the Snap version, the version.txt file has "${version}" in it.

    Note, I don't actually have a question. I am just adding some info so that maybe future versions of the installer can support Snap.
    Last edited by geekEE; 05-30-2021 at 02:15 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •