Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 2 of 2

Thread: Feedback Problem on Mic input with custom Audio Adaptor Board

  1. #1
    Junior Member
    Join Date
    Nov 2020
    Posts
    5

    Feedback Problem on Mic input with custom Audio Adaptor Board

    Hi,

    for a University Project, I designed a custom Audio Adaptor Board (based on the official Audio Adaptor Board Rev C). With the second revision of my PCB, I face the following Problem: when touching the mic input (at high gains), the board goes into some sort of self-oscillation/feedback. Without any speaker or microphone connected. Probably the mic input is electromagnetically coupling with the line output. If I remove the 2.2k Mic Bias Resistor the problem disappears. Any hints on avoiding this problem when designing the PCB? If you want, I can send you the KiCad Project.

    Best,

    Pascal

  2. #2
    Senior Member
    Join Date
    Jul 2020
    Posts
    1,180
    Don't touch it then! Better still just ground the mic input.

    The problem is that the 2k2 resistor couples the input to the supply rail, and the supply rail has some output modulated on it.
    With a microphone connected the low impedance shorts out that route for feedback.
    You could also split the resistor in 200 and 2k, supply - 200 - X - 2k - microphone.
    Decouple point X to ground.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •