Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 6 of 6

Thread: Looking to use Little FS with platformio and Teensy 4.0

  1. #1

    Looking to use Little FS with platformio and Teensy 4.0

    I am trying to get littlefs working with platformio and teensy 4.0. I have added the little fs wrapper library paul made at https://github.com/PaulStoffregen/LittleFS but I am having trouble compiling, and getting lots of errors. I think I am missing some file somewhere but I don't know what. here is what the log shows on compile. https://pastebin.com/rKmDxaTK

    When I look into the file itself all the errors are in the littleFS .h file. I'm still pretty new to using other people's libraries and code so I am likely missing something obvious. thanks for any help your can provide!

  2. #2
    Senior Member
    Join Date
    Apr 2014
    Location
    Germany
    Posts
    9,437
    - framework-arduinoteensy 1.154.0 (1.54)
    Yes, you need 1.56 - or use an older version of Paul`s LittlFS wrapper.

  3. #3
    Thank you!

  4. #4
    So I am following up on this. I have attempted to link to paul's github to resolve this issue. In the platformio .ini page I have placed
    Code:
    platform_packages =
        framework-arduinoteensy@https://github.com/PaulStoffregen/cores.git
    Then I try to compile it I get the following error https://pastebin.com/60kKxN4c

  5. #5
    Senior Member+ mjs513's Avatar
    Join Date
    Jul 2014
    Location
    New York
    Posts
    7,692
    Quote Originally Posted by warpigs330 View Post
    So I am following up on this. I have attempted to link to paul's github to resolve this issue. In the platformio .ini page I have placed
    Code:
    platform_packages =
        framework-arduinoteensy@https://github.com/PaulStoffregen/cores.git
    Then I try to compile it I get the following error https://pastebin.com/60kKxN4c
    A bit confused you. If you are using Teensyduino 1.54 littleFS is already a part of the TD install package. Been that way for a while. You shouldn;t be using the Github version since its configured to use 1.56beta2.

    Its not just the core you would need to update but SD and SDFat libraries if you want to use the latest version of LittleFS instead of the packaged version with TD1.54 which you have as part of your PlatformIO already. Maybe better to back out the changes.

  6. #6
    Okay, so if I am using teensyduino 1.54 and want to use littleFS how do I include the correct library? when I get rid of the platform packages line to use framework 1.54 and also remove the libdeps line to stop pulling the most recent littlefs wrapper from pauls's git, I still get the same errors as my initial problem. My assumption is that it is trying to pull the most recent littleFS version rather than use whichever works/comes with teensyduino 1.54.

    For what it is worth I did manage to get it working in regular visual studio with the visual micro addon. This is with the beta 1.56 and pulling littleFS from paul's git. I would like to get it working with platformio but it isn't critical.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •