Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 2 of 2

Thread: Error in compiling TheensyThreads.cpp

  1. #1
    Junior Member
    Join Date
    Jan 2021
    Posts
    9

    Error in compiling TheensyThreads.cpp

    Hi!
    After installing the latest Arduino IDE 1.8.16 and Teensyduino v.1.55 I've experienced an error in compiling code that worked with the previous version of Teensyduino.

    The problem is on line number 29 of TeensyThreads.cpp which reads: #include "utils/debug.h".

    When the line is commented out the compilation terminates without any problem.

    //Göran
    Attached Files Attached Files

  2. #2
    Senior Member+ defragster's Avatar
    Join Date
    Feb 2015
    Posts
    15,271
    This is a reported issue : github.com/ftrias/TeensyThreads/issues/29

    Hopefully updated for inclusion in TD 1.56 in Beta?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •