Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 15 of 15

Thread: Two Teensy 3.2 and one program

  1. #1
    Junior Member
    Join Date
    Apr 2021
    Posts
    8

    Two Teensy 3.2 and one program

    Can somebody help me: one program give me two different results with two Teensy 3.2 ?
    I can understand ...

  2. #2
    Junior Member
    Join Date
    Apr 2021
    Posts
    8
    Is it a question of firmware ?

  3. #3
    Member
    Join Date
    Jul 2014
    Location
    Currently Sarande, Albania
    Posts
    66
    pgu:
    did you not see this rule at the top of the page?
    Forum Rule: Always post complete source code & details to reproduce any issue!

    Nobody here can help you with the information you have posted in these 2 messages.

    Regards,
    Ed
    Last edited by sbfreddie; 04-03-2022 at 02:23 PM. Reason: Bad Auto correction problem

  4. #4
    Junior Member
    Join Date
    Apr 2021
    Posts
    8
    In the program, there are more than on thousand lines …

  5. #5
    Senior Member+ defragster's Avatar
    Join Date
    Feb 2015
    Posts
    16,214
    Quote Originally Posted by pgu View Post
    Can somebody help me: one program give me two different results with two Teensy 3.2 ?
    I can understand ...
    Ideally yes, someone can help.

    But more details and information would be needed.

    Are the two T_3.2's identical? Purchased from a good source and not counterfeit? What is the nature of the differing results? Maybe one is damaged, or it is relying on internal information like serial # or EPROM stored data? Id it really the same firmware uploaded and running?

    Something is different with the two units, or the same code would give the same results.

    More info is needed to have any understanding of the issue ...

  6. #6
    Junior Member
    Join Date
    Apr 2021
    Posts
    8
    The two T__3.2 are the same and bought from a legitimate source, the assembly contains a webcam and a Lora transceiver module.
    On the gateway side (which is a Raspberry), the image is good and on the other the image is black.
    Already tested: the webcam and the Lora module. This is not the origin of the problem.
    How can I get the T___3.2 firmware reference? Does anyone know?
    Tanks for your help.

  7. #7
    Junior Member
    Join Date
    Apr 2021
    Posts
    8
    If not the firmware reference, something which help me to distinguish one from the other one.

  8. #8
    Senior Member+ manitou's Avatar
    Join Date
    Jan 2013
    Posts
    2,713
    Quote Originally Posted by pgu View Post
    In the program, there are more than on thousand lines …
    Your assignment is to produce the smallest sketch that behaves differently on your T3.2s -- and then post that sketch to this thread so others can try.

  9. #9
    Senior Member
    Join Date
    Nov 2012
    Posts
    1,876
    How can I get the T___3.2 firmware reference?
    What do you mean by "firmware reference"? The firmware is your code.

    something which help me to distinguish one from the other one
    Distinguish which one from which other one? If you mean the T3.2, they should be the same.
    If you mean the code in each T3.2, you can't get at it. Once the code has been compiled and uploaded, you can't read it from the T3.2

    The two T__3.2 are the same and bought from a legitimate source
    OK. What is the legitimate source?

    Pete

  10. #10
    Junior Member
    Join Date
    Apr 2021
    Posts
    8
    @manitou,
    I meet the matter with the current code ...
    If I test the blinking program, sure that they are going to give the same results on the the T3.2. We should find a smaller program which give result different on the 2 T3.2, but ...

    @el_supremo
    Firmware reference = firmware version
    One T3.2 from the other T3.2
    Legitimate source: Digikey, Mouser or Farnell

    pgu

  11. #11
    Senior Member
    Join Date
    Nov 2012
    Posts
    1,876
    It's not clear to me what the hardware setup is like. Do you have two completely separate installations, one works and the other doesn't. When you exchange the T3.2 between the two setups, the problem switches with the processor.
    Or you have one hardware setup with a socket for the Teensy 3.2. One T3.2 works but if you replace it with the other T3.2 then it fails?

    Since you're asking about firmware versions, it suggests that perhaps you aren't certain that the code in the two T3.2 is exactly the same. Can you upload the same version to both T3.2 and try them?

    Pete

  12. #12
    Junior Member
    Join Date
    Apr 2021
    Posts
    8
    Two T__3.2 and one hardware setup with aprogram give two different results.
    I have one hardware setup with a socket for the Teensy 3.2. One T3.2 works but if I replace it with the other T3.2 then it fails.
    I confirm that the same code is uploaded to both, and the hardware setup works with one T_3.2 and fails with the other T_3.2

    pgu

  13. #13
    Senior Member
    Join Date
    Nov 2012
    Posts
    1,876
    Can you post photos of the two Teensys?

    Pete

  14. #14
    Junior Member
    Join Date
    Apr 2021
    Posts
    8
    Click image for larger version. 

Name:	Photo1.JPG 
Views:	21 
Size:	132.4 KB 
ID:	28045
    Click image for larger version. 

Name:	Photo2.JPG 
Views:	24 
Size:	81.1 KB 
ID:	28046

  15. #15
    Senior Member
    Join Date
    Nov 2012
    Posts
    1,876
    Can you also post photos of the underside of each Teensy?

    Pete

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •