I recently bought a Teensy 4.1 with the pins soldered and when I tried to plug it into a computer running windows with a micro usb cable with data capabilities, it did not recognize it and the LED did not turn on. I measured the voltage in the 5V and 3V pins and got 5V and 3.28V respectively. Power was being supplied but there was no visible output in terms of the connection to the windows device and the LED in the Teensy. I read on the Troubleshoot page that Teensy's tend to have some detection problems on windows so I tried plugging it into a Mac and got the LED to turn on but it was a faint light without any blinking. At the same time, the Mac was not recognizing the Teensy. I did notice that when the micro usb cable was moved or twisted, the LED had a greater intensity to its light. Different micro usb cables were tested yet they all gave the same result. Another Teensy 4.1 with the pins soldered was also tested using the same computer and cable and it worked perfectly. Is this something that is caused by a faulty micro usb port on the Teensy? Some sort of mishandling?

Thanks in advance!!