Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 3 of 3

Thread: 2x Teensy 4.1 USB serial port, one is not working

  1. #1

    2x Teensy 4.1 USB serial port, one is not working

    Hi,
    I have 2 nearly identical Teensy 4.1 boards. The only visual difference I have observed is that the version of the CPU is different: the bottom code for the working one is CTGA2211G, the bottom code for the faulty one is CTEW2208H.

    Now the issue I am having:
    I am trying to have the Teensy enumerate a serial port (over USB) in Windows 10, I use the following very simple code from https://www.pjrc.com/teensy/td_serial.html:
    Code:
    void setup() {
      Serial.begin(9600); // USB is always 12 or 480 Mbit/sec
    }
    
    void loop() {
      Serial.println("Hello World...");
      delay(1000);  // do not print too fast!
    }
    I hit "Upload", the program compiles and the teensy.exe programming GUI opens. I press the programming button and programming proceeds without any warnings or errors.
    The resulting behaviour however is very different:

    On device 1 (CPU code CTGA2211G), I now see "Hello World..." in the serial terminal (as expected).

    On device 2 (CPU code CTEW2208H), I see nothing in the terminal. I do see the LED blinking intermittently though: 7 blinks, about half a second apart, then 2-3sec nothing, then the blinking repeats.
    What could be going on? Is this some blinking of the bootloader, indicating something? I cannot find anythink on bootloader blink codes.

    edit:
    P.S. I tried swapping USB cables, that does not make any difference. I also looked at the log from the programming GUI, the output for both boards is identical.
    P.S. 2: this error is not limited to serial at all, see below.
    Last edited by f.d.roscamabbing; 11-22-2022 at 02:21 PM. Reason: add some debug info

  2. #2
    Senior Member+ KurtE's Avatar
    Join Date
    Jan 2014
    Posts
    11,151
    There is blink information on the page: https://www.pjrc.com/store/ic_mkl02_t4.html
    Look toward the end of it, under troubleshooting.

    Not sure it would help in this case, but you might try the 15 second or so reset of the not working T4.1. Hold the program button down for like 15 seconds (maybe 20...) until hopefully you see the program led blink. then release. Hopefully
    it will then reprogram the teensy with the shipping sketch and get the simple blink on the main LED (pin 13)

  3. #3
    Thanks for the link.
    It states the 7 blinks is the following:

    7 Blinks = ARM JTAG DAP Communication Error
    A communication error was detected, but after correctly detecting (4 blinks) and initializing the ARM JTAG DAP (9 blinks). Programs which crash or have unusual startup behavior can cause a temporary 7 blink error at startup. With a known-good program or blank flash chip, this error may indicate a severe signal quality problem or any of the signal wires shorted to other lines which are initially high impedance but become output after a program is running. But these types of hardware issues are unusual, because hardware trouble for 7 blinks requires first successfully passing tests which would cause 4 or 9 blinks. 7 blinks can also be shown if the processor reboots, either by software write to SCB_AIRCR or due to fault or other error handling, while communication is in progress. If you see 7 blinks, program the flash memory with a simple known-good code before investigating hardware trouble.


    So I tried a very simple LED blink program, turns out that that also won't run so it doesn't have anything to do with Serial per se. Let me see if I can change the topic title.
    I did a thorough visual inspection of the board under a microscope, but I see nothing that would explain this behaviour. Maybe something internal got fried.

    I am not fully understanding the error though. Does it have anything to do with the communication between the MKL02Z32VFG4 chip (another microcontroller) and the main CPU?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •