Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 12 of 12

Thread: Arduino 2.0.3 FQBN Error

  1. #1

    Arduino 2.0.3 FQBN Error

    I am trying to get a project to work with Arduino 2.0.2 which did work once or twice and I can get to work with Arduino 1.8.19

    I select Teensy 4.1 and the Port and the USB type (Raw Hid project) and I get

    Invalid FQBN: not an FQBN: teensy:avr:teensy41:usb=rawhid:usb=rawhid,speed=60 0,opt=o2std,keys=en-us

    Compilation error: Invalid FQBN: not an FQBN: teensy:avr:teensy41:usb=rawhid:usb=rawhid,speed=60 0,opt=o2std,keys=en-us

    The port does show up as a Raw HID with the VID and PID - maybe that's related to the issue? "hid#vid_16c0&pid_0486 RawHID (Teensy4.1)"

    Simon

  2. #2
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    27,366
    First, check File > Prefs. The URL needs to be this:

    https://www.pjrc.com/teensy/package_teensy_index.json

    If it has "156", delete the old URL and use this one.

    Then in the Boards Manager, install version 1.57.1. If you have 1.57.0, you'll probably see this FQBN error. Updating to 1.57.1 should fix it.

  3. #3
    Hi,
    Thanks for the fast answer.
    Seems good now!
    Simon

  4. #4
    Senior Member
    Join Date
    Feb 2020
    Posts
    143
    Hi Paul, I have been seeing the same error using 1.58.0-beta2. Having to repick the board as 4.1 most of the time fixes it. Sometimes it happens when i have more than one instance of the IDE running. Also when using a new never programed 4.1, when i initially plug in the usb to the board there is no serial port listed in device manager. Once I pick the HID port under ports in the IDE and program something like the blink program then the serial port shows up in device manager and i can pick it under ports.
    Windows 10
    teensyduino 1.58.0-beta2
    Arduino 2.0.2 IDE

  5. #5
    Senior Member
    Join Date
    Feb 2020
    Posts
    143
    Complete Error msg:

    Invalid FQBN: not an FQBN: teensy:avr:teensy41:usb=serial:usb=serial,speed=60 0,opt=o2std,keys=en-us

    Compilation error: Invalid FQBN: not an FQBN: teensy:avr:teensy41:usb=serial:usb=serial,speed=60 0,opt=o2std,keys=en-us

    I just noticed after a restart of 2.0.2, I saw this error while the bar above said Teensy 4.1. But when I looked under tools>boards>teensy Tensy 4.1 was not checked. After I selected teensy 4.1 no more errors. I this an Arduino bug?

    Windows 10
    teensyduino 1.58.0-beta2
    Arduino 2.0.2 IDE[/QUOTE]

  6. #6
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    27,366
    Ok, I know this sounds strange, but trust me...

    Use Boards Manager to install 1.57.1. It should solve the FQBN error. Then use Boards Manager to go back to 0.58.2. You should see the FQBN error is magically fixed, even after no longer using 1.57.1.

  7. #7
    Senior Member
    Join Date
    Feb 2020
    Posts
    143
    I went back to 1.47.1 and 1.58.2 is not in the boards manager dropdown?

  8. #8
    Senior Member+ KurtE's Avatar
    Join Date
    Jan 2014
    Posts
    11,375
    Paul renamed it, such that those who wanted to only run released versions would keep being asked if they
    want to upgrade their board...

    it is now .58.2

    And yes you will then keep getting the prompt if you wish to update to the latest... Unless you go and turn that off.

  9. #9
    Senior Member
    Join Date
    Feb 2020
    Posts
    143
    Oh, that makes sense! Thanks Kurt!

  10. #10
    Senior Member
    Join Date
    Feb 2020
    Posts
    143
    FYI:
    Received these messages when i installed .58.2
    Configuring platform.
    Platform teensy:avr@0.58.2 installed
    Uninstalling teensy:avr@1.57.1
    Error upgrading platform: platform not installed
    Uninstalling teensy:avr@0.58.2
    Platform teensy:avr@0.58.2 uninstalled
    Failed to install platform: teensy:avr.
    Error: 13 INTERNAL: Cannot upgrade platform: platform not installed


    Boards manager says version is 0.58.2, is this normal?

  11. #11
    Senior Member
    Join Date
    Feb 2020
    Posts
    143
    Ok so i restarted 2.0.3 and boards manager showed tensyduino was not installed at all. I installed 1.57.1. Restarted 2.0.3 and upgraded to 0.58.2 and it seemed to work this time.

    This is the output:

    Tool teensy:teensy-tools@0.58.2 already installed
    Tool teensy:teensy-compile@11.3.1-beta1 already installed
    Tool teensy:teensy-discovery@1.57.1 already installed
    Tool teensy:teensy-monitor@1.57.0 already installed
    Downloading packages
    teensy:avr@0.58.2
    Replacing platform teensy:avr@1.57.1 with teensy:avr@0.58.2
    Uninstalling teensy:avr@1.57.1
    Platform teensy:avr@1.57.1 uninstalled
    Uninstalling teensy:teensy-tools@1.57.1, tool is no more required
    Uninstalling teensy:teensy-compile@5.4.1, tool is no more required
    Tool teensy:teensy-compile@5.4.1 uninstalled
    Uninstalling teensy:teensy-discovery@1.57.1, tool is no more required
    Uninstalling teensy:teensy-monitor@1.57.0, tool is no more required
    Configuring platform.
    Platform teensy:avr@0.58.2 installed

  12. #12
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    27,366
    Maybe in File > Prefs you have the older index URL, the one with "156" in the middle?

    I recently deleted the old index file and made it a symbolic link to the main one. If you had stuff installed which isn't in the newer file, that probably caused Arduino to do weird things.

    Until Arduino adds better support for publishing beta versions, all betas will start with 0 as their major version number. We learned the hard way with the old index file that naming them as before with a separate installer for Arduino 1.8.x causes Arduino 2.0.x to prompt all users to replace their stable install with the latest beta.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •