Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 2 of 2

Thread: Teensy 4.1 intermittently detected by macbook M1 Teensyduino

  1. #1
    Junior Member
    Join Date
    Nov 2022
    Posts
    1

    Teensy 4.1 intermittently detected by macbook M1 Teensyduino

    Hello,

    I am starting a new project using a Teensy 4.1. I am currently using an Apple M1 Pro (14 inch 2021) running Mac OS 12.5 (Monterey).

    I have a curious issue with my Teensy 4.1. I am currently running TeensyDuino version 1.57 and trying to load programs using it and while I able to load the blink program a couple times initially, now I have an issue where my Teensy is not detected by laptop at all for a long time, and suddenly I can detect it, load programs as usual etc. There doesn't seem to be any pattern to when its detected and programmable from my laptop, but this makes it really hard to actually use for my project. Any ideas what could be causing this?

    For what its worth, I did solder the header pins onto the teensy myself, so perhaps I caused an issue there?

  2. #2
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    27,406
    Can you be more specific about "not detected by laptop at all". Remember, nobody can see your screen or see which things you are attempting and the results your observing. Please try to be specific about the exact actions you are performing and what you actually observe.

    Just yesterday I spent several hours using Teensy 4.1 with a M1 Mac Studio, plugged into a powered USB hub which was connected to one of the 2 front ports by a cable about 3 meters long. Definitely did work. But I don't have any of the newer M1 laptops.

    For the sake of testing, please keep the small Teensy Loader window visible. Turn off "Auto" mode, so it won't quickly reprogram and reboot Teensy (allowing you plenty of time to see the results) and try pressing the pushbutton on Teensy. When you hold the button down, Teensy should disconnect. Within 1-2 seconds after releasing the pushbutton, Teensy Loader should respond.

    Usually soldering pins shouldn't cause a problem with the USB. But some types of solder have a flux chemical which needs to be cleaned away. How to do this depends on the chemical. Some dissolve with isopropyl alcohol. If you get 99% isopropyl (available at many pharmacies) the alcohol evaporates away quickly after cleaning. Other types of flux are designed to dissolve with ordinary water, which is easy but usually the excess water needs to be dried by baking in a low temperature oven for several minutes. However, for many of the common types of solder, the flux chemical is non-conductive and non-corrosive, so cleaning is considered unnecessary, only done for cosmetic appearance.

    Another simple thing to try is a different USB cable. The most common problem is charge only cables that have no data wires at all. But we've also seen really low quality cables from time to time, which work fine with 12 Mbit speed devices but aren't reliable with 480 Mbit speed which Teensy 4.1 uses. Placing a USB hub between your Macbook and Teensy might also have an effect, perhaps helpful, maybe not. Might be worth a try.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •