Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 8 of 8

Thread: Arduino IDE2.0 with Teensy 4 question on libraries

  1. #1
    Senior Member
    Join Date
    Jan 2014
    Posts
    213

    Arduino IDE2.0 with Teensy 4 question on libraries

    Are you experts using Arduino 2.0 ?
    I have been using Arduino 1.x for many years and have developed quite a few libraries.
    I am always in the middle of a few projects and have not changed over to Arduion 2.0, PlatformIO or Visual Studio/Visual Micro...etc.

    Any suggestions?
    I have installed Arduino 2.0 and it appears that all libraries go into the sketch folder under libraries. Do I just copy my libraries from my hardware\teensy\avr\libraries into that sketch\libraries?

    Am I entering a rabbits hole? (I dig enough of my own)

    thanks,

    Richard

  2. #2
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    27,370
    Info here:

    https://www.pjrc.com/arduino-ide-2-0-0-teensy-support/

    The install process using Arduino 2.0.x Boards Manager installs a copy of all the same libraries as you would get from the old installer with Arduino 1.8.x.

  3. #3
    Senior Member
    Join Date
    Jan 2014
    Posts
    213
    Thanks Paul,
    I found where the libraries were stored in:
    C:\Users\Richa\AppData\Local\Arduino15\packages\te ensy\hardware\avr\1.57.1\libraries

    and was able to replace one (FastLED) that I had modified. I will submit my changes for inclusion in that library.

  4. #4
    Senior Member
    Join Date
    Jan 2014
    Posts
    213

    Need some help with Teensy 4.0 and Arduino 2.0

    Yup, I'm in a rabbit hole.

    1. Loading both Arduino 1.8.15 and Arduino 2.0 My Arduino 1.8.15 can no longer find the libraries that are in C:\Arduino\hardware\teensy\avr\libraries.

    2. Running on Teensy 4.0, I can compile and run correctly, however, I see no serial output. I have to close Arduino 2.0, open a serial monitor, and I see the proper serial output. This is clearly unacceptable.

    Any help? Thanks

  5. #5
    Senior Member
    Join Date
    Jan 2014
    Posts
    213
    I tried my Hello World on a Teensy 3.6 and get no serial output either (although Arduino 2.0 does compile and execute (I can see led blinking on Teensy).
    Maybe some cross issue from my using TyCommander with 1.8.15?

  6. #6
    Senior Member
    Join Date
    Jan 2014
    Posts
    213
    I had to reload TeensyDuino for Arduino 1.8 to find libraries.

    Now I just wish I could see serial output on Arduino 2.

  7. #7
    Senior Member
    Join Date
    Jan 2014
    Posts
    213
    Okay Solved Serial problem in 2.0. Small step for mouse brain.

    In Tools Port There are 2 options
    COM3
    COM3 Serial Teensy 4.0 (selected at default installation).

    The COM3 has to be selected to see Serial output.

  8. #8
    Senior Member+ KurtE's Avatar
    Join Date
    Jan 2014
    Posts
    11,379
    Serial monitor at times has some issues -
    I assume you clicked to open the Serial Monitor and see the windowpane at the bottom of the window, that should have your Serial output. (Same place as program builds output) but with different tab chosen.

    There are times issues with the choosing the Arduino port section for the Teensy Serial port versus the Teensy part. Some of this is mentioned in a few threads including:
    https://forum.pjrc.com/threads/71588...-Upload-Thread

    I have both installed. Note: 2.0.2 is in the normal place mentioned

    As for 1.8.15? I as assuming you installed Arduino into the folder mentioned.
    Note: there was an issue with having Arduino 2 installed that even if you built using Arduino 1.8.x it was using the files out of the Standard Arduino install location.

    Paul fixed that we current releases of teensyduino (I believe by changing the boards.txt and/or platform.txt).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •