Macintosh Teensy3 Errors (fixed by Teensyduino version 1.16)

Not open for further replies.


Active member
Paul, just wondering if you have any idea what is going on?

(Arduino 1.0.5, Teensyduino, Teensy3)

Here is the trend.

Teensy3 is not visible in serial port.
I click upload, it asks me to reset the board.
I reset, Teensy3 is now (magically) visible in serial port.
I proceed to upload, receive error 'download error' from teensy loader
Teensy3 vanishes from serial port

Uploading/rebooting all prompt 'download error' (see image)

Just trying to upload the blink code as a test.

This Teensy3 was working perfectly a few hours ago and I am measuring 5V across it.

Screen shot 2013-06-10 at 3.25.16 PM.png
Restarted my computer, everything went back to normal.

Teensy3 is working fine now.

Oldest trick in the book.
Are you using a Mac?

I often have to unplug and replug my Teensy 3.0 after loading new code before the OS will see it.
Which Mac, and which version of OS-X? Also, which port is the Teensy plugged into? Does it change if you plug into a hub (like the Apple keyboard USB ports) vs directly?
I haven't tried with a hub. It is the same on both ports
I have Mountain Lion on a newish MacBook Pro laptop.

I don't need to do a full reset - I just unplug and replug the teensy.

This is a minor annoyance compared to what I have to do to get the Leonardo boot loader to work. Why do they ship products with that?
I have to explain the mysterious double reset trick to everyone I know who gets stuck with Esplora or Lilypad USB.
Last edited:
I have a Macbook Air with 10.8. I tested on that machine some time ago (mainly to check how things work with the new 10.8 Gatekeeper stuff), but I only did a few uploads. That little Air is a great laptop for travel, but it's pretty tiny for actually using Arduino.

Can you give me any more hints about what to try? Just plug in a Teensy3 and repeatedly upload the blink example every 10 seconds?
I have a Macbook Air with 10.8. I tested on that machine some time ago (mainly to check how things work with the new 10.8 Gatekeeper stuff), but I only did a few uploads. That little Air is a great laptop for travel, but it's pretty tiny for actually using Arduino.

Can you give me any more hints about what to try? Just plug in a Teensy3 and repeatedly upload the blink example every 10 seconds?

I just started using my Teensy3 today for touchRead()...
I will update you if I determine exactly what induces this goofiness...
teensy3 stability?

I find the teensy3 extremely frustrating. I am doing simple multiple i2c sensor collection. The data collected is fine. But accessing the data from the teensy3 is less than reliable. Is the problem arduino? serial monitor? teensy loader? The problems I have are:

1) serial monitor randomly locks up. Its not a particular data size.
2) teensyloader gives me can't upload error.
3) teensyloader gives me can't reboot error.

I am using OSX 10.8.3 if that matters - Xcode apps and linux apps I've coded on other mcu platforms do not give me the same headaches. I've done all the arduino and teensyduino updates.

I like the footprint (and horsepower) of the teensy3. But, have no tolerance for these technical problems. If there is a solution I've missed, I'll gladly implement. Otherwise, moving onto another platform.

I wanted to add, the only solution I have is unplugging the USB cable (a random number of times) - it eventually comes back.

And also wanted to add something about the runtime.

I can collect data from one sensor (they are all identical), and do some very basic math (filtering) in ~1.7ms. When I integrate and collect data from four sensors, the time jumps to ~16ms. I did it in a for loop. I have not unrolled and collected the execution time - but I was hoping to get ~8ms total execution time. I've got to leave it alone for tonight before I chuck it in the rubbish.
Last edited:
teensy 3.0 Download Error

Hi there,

i always get a problem after downloading a program 5-10 times to the teensy.
first teensyduino is unable to reboot the teensy and in the following download sequence it fails writing the program.

i tried it with both teenys i actually have.
running arduino 1.05 and teensyduino 1.14 rc3 and tried programming serveral programms even with the simple blink example the problem occured.
tried serveral usb cables and have a mbp 10.8.4.

attached two verbose info files. do you need more infos?

greetings and thx,


  • TeensyWriteError.pdf
    52.5 KB · Views: 222
  • TeensyWriteError2.pdf
    43.5 KB · Views: 257
Macintosh Teensy3 Errors

I'm starting this new thread to consolidate all the separate threads about problems on Macintosh. I'm going to dig into what's going wrong on Mac. Having all the conversation in a single thread should help.
Ok, I'm able to reproduce the problem here on a Macbook running OS-X 10.7.5. With the LED blink example, the first several uploads work, then it starts running into problems. I just tried it with 17 successful uploads, then errors.

I will investigate today and post here as I learn more. Please subscribe to this thread if you're experiencing this problem on a Mac. When I figure out what's going on and try a new version to fix this, I'll really need your help testing.
I worked on this yesterday. I can see Mac OS-X is doing strange things, but I still don't know why or what to do to fix this. I am working on it and I'm confident I'll eventually get this fully resolved, but it may take some time.

I do have one quick question, or one thing I'm hoping you can test for me on your Mac? When the errors start and you can no longer upload to Teensy, which of these restores the upload to working again:

  • Reboot the Mac (but leave the Teensy3 connected the whole time)
  • Unplug and reconnect the USB cable
  • Hold the Teensy3 button for 5 seconds
Last edited:
cool, that you try to fix the prob that fast!

what helped and what not:
didn´t help:
- holding reset button for 5 secs
- unplugging USB
- closing teensyloader

- reboot mac, with option all windows reopen at startup, but teensyloader was closed and reopen with upload process ( can´t say if this maybe works not every time, only tried once)
- unplugging USB cable and closing teensy loader, plug the cable and upload (teensyloader starts automatically) works in most chases (maybe 85%)

hope i could help and you´ll find the error soon!
Ive had this problem before as well. Closing the Arduino IDE and Teensy loader and unplugging the USB cable worked in my case. (i7 iMac OSX10.8.3 updated to 10.8.4 yesterday).

One thing to look out for is to make sure that you have the correct teensy loader running. I tend to start most applications using Spotlight. If you have several Arduino and Teensyduino versions installed that may not start the Teensy loader that works with the Arduino/Teensyduino version that you are working in at the moment.
This worries me, that I might not have truly reproduced the same problem?

didn´t help:
- holding reset button for 5 secs
- unplugging USB

Both of these "fix" the problem here, at least for another 10 to 20 uploads, then it reappears.

At this point, I can see the Mac is doing strange things, but I must confess I do not yet understand why. It's quite possible whatever's going wrong is just slightly more severe on your Mac? It's still a mystery.

As I get farther into this, I'll probably post an experimental version of the Teensy Loader here, which puts a LOT more into the verbose info window. Even that is proving to be tough. I'm using Apple's HID Manager API, which adds a pretty substantial layer on top of the raw device and makes troubleshooting more difficult. It seems 10.6 might have added some new functions to get references from this API to the lower level stuff, but Apple has very little documentation on that.
I have a similar problem on my MacBook pro with 10.8.4
After a few uploads I get an error. To fix it I usually just press the button on the teensy once and it solves the problem.
I'm having a similar problem, but worse. I can get the teensy loader to load at all. The reboot and upload buttons stay greyed out, and the verbose information is telling me "HID/macos: no devices found". I've tried every combination of button pressing, unplugging rebooting and sacrificing goats that I can think of.

In the system profiler I can see it on the USB:

USB Serial:

Product ID: 0x0483
Vendor ID: 0x16c0
Version: 1.00
Serial Number: 12345
Speed: Up to 12 Mb/sec
Manufacturer: Teensyduino
Location ID: 0xfa222000 / 9
Current Available (mA): 500
Current Required (mA): 100

I'm not seeing anything in /dev/ though. This is on a laptop with 10.7.5 and a desktop with 10.8.4 installed.
I can't find the Teensy Loader 1.07 to use my Teensy3. I installed the Teensyduino as the trouble shooting section implies.

Is the 1.07 loader a standalone application? Is it only accessible through Arduino software by pressing the Verify button? That causes errors:

Arduino: 1.0.4 (Mac OS X), Board: "Teensy 3.0"
/Applications/ -c -g -Os -Wall -fno-exceptions -ffunction-sections -fdata-sections -mcpu=cortex-m4 -DF_CPU=48000000 -MMD -DUSB_VID=null -DUSB_PID=null -DARDUINO=104 -mthumb -nostdlib -D__MK20DX128__ -fno-rtti -felide-constructors -std=gnu++0x -DUSB_SERIAL -DLAYOUT_US_ENGLISH -I/Applications/ /var/folders/ug/ugrO3QWIG-m8xCCdQzerGU+++TI/-Tmp-/build5970299649987646825.tmp/Blink.cpp -o /var/folders/ug/ugrO3QWIG-m8xCCdQzerGU+++TI/-Tmp-/build5970299649987646825.tmp/Blink.cpp.o

What's should be my next step to get the compiled HEX file to upload on Teensy3?
The message you've posted does not look like an error. Is that all of the output you are getting ?

But to answer your question you can find the teensy loader in:

"Error reading Teensy Loader status! (tr)This error should never happen."

My ability to update the program on my Teensy 3 is intermittent with various failure modes. I've included as much output as I can find below on a recent one. I work around this by retrying the upload, unplugging the USB cable, or power cycling the T3. I haven't counted but upload problems happen several times an hour when I'm uploading code frequently.

Sometimes, the Arduino environment reports a "shouldn't happen" error. Sometimes it claims the Teensy Loader is busy. Sometimes when it claims the Teensy loader is busy, it works anyway. Sometimes the Teensy loader hangs erasing the part. There isn't a single consistent pattern to it.

For what it's worth, I also have trouble connecting the serial monitor both from the Arduino environment and from the command line using the cu command, like this:

sudo cu -l /dev/tty.usbmodem* -s 9600 --nostop --parity=none

The laptop I'm using is a 2007 MacBook Pro running OS X 10.8.4. This model runs hot and is prone to problems with the Nvidia graphics chip.


  • t3_verbose.txt
    31.7 KB · Views: 222
  • t3_compiler_output.txt
    14.6 KB · Views: 222
  • t3_compiler_output2.txt
    28.8 KB · Views: 212
This is a very small bug that is not limiting function but can be a bit confusing.
The info.plist fine in the teensy 1.15 loader app still lists it as Version 1.07.
So when you start the app manually and select "Teensy" --> "About" it'll still show the correct version 1.15 but in Finder it shows 1.07.
If that's corrected in te info.plist file it will also show correctly in the Finder.

Screen Shot 2013-07-03 at 3.43.36 PM.png
Opps. Thanks for reporting this, with the nice screenshot. :)

I've added this to my bug list to fix on the next release. I have a script that auto-updates this for the Teensyduino installer, so it should be pretty simple to apply it to the Teensy Loader build too.
Not open for further replies.