Teensy 3.0 is not recognised

Not open for further replies.


Hi there!

I got my first Teensy and really like the specs and the size.

But i´ve problems to get it recognised by the teensy loader.
I´ve installed Arduino 1.0.4, Teensyduino 1.14 (Teensy 0.7).

I tried 4 USB cables and tried all the steps in the troubleshoot section.
I only want to try to programm the BasicTest from OctoWS2811.

When i received the board the blink program ran, but if i pushed the button the LED still blinked further.
Once i could load the BasicTest onto it after 50 tries, but now it didn´t worked for 100 tries...
And it´s the same with the Push Button, the programm still runs if i press it.

Have a mid 2012 MacBook Pro with OS X 10.8.3.

Do you´ve any more tipps i could try?
i´ve an oscillospe and a logic analyser.

Thx for your help and greetings from germany.

Screen Shot 2013-05-13 at 1.36.47 PM.png
Last edited:
When i received the board the blink program ran, but if i pushed the button the LED still blinked further.

It's definitely supposed to stop blinking when you press the button! Maybe the button was damaged during shipping?

The good news is the rest of the board appears to be working properly, based on the info you posted.

You can "press" the button by shorting the PROG and GND pins, on the right hand side of the board (opposite the USB). It's ok to use a wire or paperclip to short them (or solder a pushbutton to those 2 pins if you like). Touch the wire to GND first (in case your body has any electrostatic charge) and then momentarily touch it to the PROG pin. The button just connects those 2 wires, so touching a wire between those pins does the same thing.

Normally while using Arduino, you can just click the Upload button. It will search for your Teensy and send a request to reboot. As long as it's still running (hasn't crashed with interrupts disabled or locked up due to a bad memory access), the board should reboot automatically without needing to press the button. This process usually works very well on Mac and Linux (usually only Windows that has driver issues).

That screenshot shows the serial number is "7018". Maybe this board has been successfully reprogrammed at least once? The code we're programming onto the boards here is from an older version of Teensyduino which didn't report the actual serial number. All serial numbers from the older version are "12345". Macs often show it as "12341" (why Apple change the last digit to a 1 is a mystery to me).
I measured the button, seems to work fine and the wire method didn´t helped at all.

Yes like i said i was once able to program the Teensy with the BasicTest OctoWS2811 code except some small changes(in bold). wanted only control the first one meter stripe.
but it worked after trying to program it 50 times.

void loop() {
int microsec = 200000 / leds.numPixels(); // change them all in 0.2 seconds //normaly 2000000 aka 2seconds

// uncomment for voltage controlled speed
// millisec = analogRead(A9) / 40;

colorWipe(RED, microsec);
colorWipe(GREEN, microsec);
colorWipe(BLUE, microsec);
colorWipe(YELLOW, microsec);
colorWipe(PINK, microsec);
colorWipe(ORANGE, microsec);
colorWipe(WHITE, microsec);

void colorWipe(int color, int wait)
for (int i=0; i < 60; i++) { //normally leds.numPixels()
leds.setPixel(i, color);

maybe there is something wrong with the MINI54TAN or a broken wire on the board to the MINI54TAN?

damn i ordered only one at this time, so i could see better if something is wrong with my setup or it´s only the board.
but ordered two new ones just now.

thx for the fast reply!
i really dont know what´s going on, but i got it two time now recognised from the teensy loader but then i got the following errors:
download error, because erasing seems to fail
unable to reboot, when trying to reboot
but it´s recognised the whole time.

what could that be?
Not open for further replies.