Arduino compile error: arm-none-eabi-g++ (gcc file?) missing


I just installed the Arduino IDE but it wasn't recognizing the plugged in Teensy 4.0 and every time I tried to verify/compile, it would throw up this error:
/Users/Username/Library/Arduino15/packages/teensy/hardware/avr/../tools/arm/bin/arm-none-eabi-g++.: no such file or directory.

Screen Shot 2023-06-03 at 1.06.51 AM.jpg

I was able to load the tutorial blink HEX files through teensy loader so alls good with communicating to the laptop. After multiple google searches and messing around, there was a prompt to install xcode (I can't for the life of me remember what I did). Once the xcode install was complete, I was able to compile and upload from Arduino. Unfortunately, I had to reinstall Arduino, and after that, the issue restarted. I wasn't able to trigger the prompt to install xcode, but I tried triggering the install through terminal only to be informed that it was already installed. I'm guessing there's some missing link to the Arduino/Teensy files.

Any ideas how to solve this?

OS: macOS Monterey Version 12.6.6
Arduino Version: 2.1.0
Teensy: 4.0
The pathname looks as if trying to use the files meant for Arduino 1.8.19, but you have Arduino 2.1.0. The Teensy package is slightly different for Arduino 2.1.x than it was for Arduino 1.8.x. Even though the code is identical, they have different boards.txt and platform.txt files adapted to each version of Arduino IDE. The files for one can't work with the other.

Try using Boards Manager inside Arduino 2.1.0 to uninstall the Teensy package. You might quit Arduino and then look in /Users/Username/Library/Arduino15/packages/teensy to check the files really are deleted. (this is a hidden folder in MacOS Finder, but it's accessible in Terminal... sorry, I don't have enough experience with MacOS to say how to view hidden folders in Finder)

Then reinstall 1.58.1 with Boards Manager, like in this screenshot (but use the latest, this image is from before 1.58 release)

Well that fixed it.
And now that I think about it, the xcode prompt came up after i reinstalled the teensy boards the same way initially.
I had replaced the platform.txt file with a modified one which I thought were fairly similar but I guess not. After uninstalling Teensy from Arduino, I deleted the Teensy Package file and reinstalled through Arduino and bam.

Thanks for the prompt response again Paul. Very much appreciated.

P.S. I don't know if it's a new thing but none of the folders were hidden for me. I was able to find the library folder in the Go menu.
Screen Shot 2023-06-03 at 11.18.21 AM.png