Unable to find Teensy Loader in Arduino IDE 1.8.19 (Teensyduino version) on a Mac


Well-known member
I'm on a Mac (Sonoma) and I've been using the latest Arduino IDE 2.2.1 lately, but had a need to use the lockable Teensy features of the 1.8.19 version. (Both latest version from https://www.pjrc.com/teensy/td_download.html (1.58) and from https://forum.pjrc.com/index.php?threads/teensyduino-1-59-beta-5.74262/ (1.59 beta5)) When trying to build and upload to a Teensy 4.1 (the correct board is selected), I see this in the output window:
Opening Teensy Loader...
Unable find Teensy Loader. (p) Is the Teensy Loader application running?
quitexit status 1
Error compiling for board Teensy 4.1.

I've never seen this before, so I tried a few troubleshooting steps:
1. Uninstalling Teensy core from the Arduino IDE 2.2.1
2. Ensuring IDE 2.2.1 is closed
3. Reinstall Teensyduino 1.58 (IDE 1.8.19) and Teensyduino 1.59-beta5 (both tried separately)
4. Rebooting

The only way I can get the 1.8.19 version to open the Teensy Loader is if I open IDE 2.2.1's version (tried both 1.59 beta 5 and 1.58), and have the1.8.19 IDE discover and use that. Has anyone seen this before?