Cannot install 1.58.1


Tried install Teensy 1.58.1 with broad manager on arduino ide 2.2.1

Failed with message
Error: 2 UNKNOWN: unexpected EOF

Do i need teensy board plugged in to install? I was trying out before buying. Thank you
I don't know what that error means. But I can say with certainty you do not need Teensy hardware connected to download or use the software. Of course, without hardware all you can do is compile programs.

Maybe something went wrong with the download? Or if you're using Windows, maybe Windows Defender or other anti-virus software made a mistake and deleted a necessary file? If just trying again later doesn't work, maybe search for into about how to clear Arduino's download cache. I know it's been discussed many times on their forum.
What is recommended dev software, Arduino, PlatformIO, or other? What are the pro and cons. Thanks
Arduino 2.x or 1.x

As can be seen at <this> page, both are fully supported, so it comes down to whichever is your personal preference. You can view full instructions for a proper install of the Arduino IDE plus the Teensyduino support at <this> page.

Hope that helps . . .

Mark J Culross
Many thanks.

Yes, I was following procedures as your web.

The message as follow

Downloading packages
Failed to install platform: 'teensy:avr:1.58.1'.
Error: 2 UNKNOWN: read tcp> wsarecv: An existing connection was forcibly closed by the remote host.

====== is your web ip address.
Google wsarecv and it pointed to github showing reported issues with same error message

I am using Windows 11, updated recently. I did not chnage any setting on the windows defender (anti-virus?) and it was running normally.

I did not seem to find Arduino "delete download cache". There are many on "delete compile cache"

Many Thanks
This "wsarecv: An existing connection was forcibly closed by the remote host" error means your internet connection is of poor quality. TCP automatically retries for small errors, but larger problems cause the connection to be lost.

The toolchain (teensy-compile@11.3.1) is a very large file. If you have poor internet connectivity or any number of internet connection problems which don't disrupt all communication, problems will usually manifest most when downloading very large files.

If you're using a laptop, try taking it to another location or use public wifi at some place like a coffee shop.