Perennial issues with Teensy 4.1 serial


Hi all,

I'm having constant issues with serial ports on Teensy 4.1 boards. Basically, my Teensy's USB serial emulation appears to be breaking.

I'll take you through the steps:
1. Upload LED blink example. Led blinks as expected.
2. Upload Serial Echo Example - serial port compltely disappears and isn't seen by computer.
3. Attempt reboots etc.
4. Eventually use the button hold mode to reflash device.
5. Start again.
6. Every so often I get around 5 or 7 status LED flashes.

This is super weird behaviour I've never seen in probably around 200+ Teensy 3 series devices.

I've tried some basic troubleshooting:

1. Try a different Teensy 4.1 - I only have two to try
2. Try a different computer and operating system (have been trying macOS silicon Venutre, x64 Mojave and Windows 10 on different machines)
3. Try different USB cables and hubs/ports.

Does anyone have any hints or ideas - I've used Teensy a lot and am surprised I'm struggling with something so basic here! I've generally been finding Teensy 4 seem a little bit flaky with usb serial compared to Teensy 3, but I might be imagining it.

Sorry not sure what is going on. But maybe some additional information might help.

What exactly are you running? Are you running the Teensy example USBtoSerial? any changes at all to the code?

Which IDE are you building with? IDE1, IDE2, PlatformIO... Which version? Which version of Teensyduino are you building with?

What if anything other than the USB cable is connected to the Teensy 4.1? Do you have wires connected up to the Hardware Serial port? Like pins 0 and 1 for Serial1?
If so are they running at 3.3v or hopefully not 5v? That is if you were going from a 3.2 or 3.5 to a 4.1 you need to make sure none of the IO pins are running at higher voltages.
I know you said you've tried different USB cables and hubs, but the behavior you're describing sounds pretty similar to what many others have seen with low quality USB cables.

Usually the cable is believed to be fine, since it always works with Teensy 3.x or regular Arduino boards. But those use 12 Mbit/sec USB speed. Teensy 4.x uses 480 Mbit/sec speed.
Hi all - thanks for the replies. I've actually gone back to my workshop and grabbed a bunch more Teensy 4.1s, to find that 4 out of 5 of them appear DOA. It could be a USB cabling issue, but I've tried about 15 cables now, and it wouldn't really explain why one of them seems totally fine - FYI these are brand new, unused, unopened boards.

EDIT: I'm sort of on a deadline will probably try to get project going on an ESP32 and don't have time basically to do any sort of comprehensive diagnosis, but from the looks of it, a bunch of these Teensys have some sort of Voltage Regulator issues - 4 of them don't seem to be delivering any power at all. The 5th one works perfectly.
All Teensy's are fully tested before they leave PJRC.

Have you soldered anything to them?
I soldered to the initial one that didn’t work, but just headers - I’ve literally used hundreds of teensys and I don’t think I’ve ever managed to kill one. The others that didn’t work were brand new. The working one out of the 5 seems to be working fine though.